Resolvendo erros: facebook social plugin: ‘root’ error

Como resolver o erro de ‘root’ causado por plugin do LikeBox do facebook adicionados via XFBML.

Faça a seguinte mudança no seu código, como no exemplo abaixo:

Obs.: Este erro só é causado para plugins adicionados com XFBML.

<div id="fb-root">
	<!-- o código do facebook abaixo -->
	<script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script>
	<fb:like-box href="http://www.facebook.com/lucasmartins87" width="292" show_faces="true" stream="false" header="false"></fb:like-box>
</div>

Viram que a diferença é apenas adicionar a div com id=”fb-root”.

Se você tem alguma dúvida ou não conseguiu resolver o problema é só comentar que nós tentamos solucionar. Abraços!

Autor: Lucas Martins

Lucas Martins é empreendedor na área de desenvolvimento de aplicações, cursou Análise de Sistemas pela FIAP e reside em São Paulo. Sempre procurando adquirir e compartilhar conhecimentos no desenvolvimento de sistemas, darei algumas dicas importantes sobre as tecnologias mais utilizadas no mercado (PHP, Ruby, Javascript, CSS, Design Patterns, OOP e etc), como também discutir outras tecnologias e linguagens de programação.

1 pensamento em “Resolvendo erros: facebook social plugin: ‘root’ error”

  1. Bom, eu estava adicionando o plugin do facebook e estava dando tudo certo, as caixinhas estavam aparecendo no site perfeitas. Mas desde ontem não consigo mais. Todas as caixinhas de todos os post agora estão com essa mensagem:

    skin must be one of the following values: light, dark

    como eu não sei nada dessas coisas não sei como resolver. Eu só sigo os tutoriais que vcs postam. or favor, me ajudem a resolver.

Leave a Reply